Hibernate Books

All times are UTC - 5 hours [ DST ]



Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Problem in Hibernate tool reverse engineering
PostPosted: Mon Jun 06, 2011 3:29 am 
Newbie

Joined: Mon Jun 06, 2011 3:02 am
Posts: 2
Hi..I have used HibernateTools-3.2.4.GA-R200903141626-H5 with Eclipse Galileo, MySql 5.0 as Database, i have created hib config file, console config fiile every thing needed, i am able to connect to database and see the tables, But the problem is it's not generating either hbm files nor java files. i tried many times but no result.

Where it messing up, i have given Output directry as ...project/src

Please help me out. Thanks in advance.


Top
 Profile  
 
 Post subject: Re: Problem in Hibernate tool reverse engineering
PostPosted: Mon Jun 06, 2011 3:34 am 
Senior
Senior

Joined: Tue Aug 04, 2009 7:45 am
Posts: 124
Look at:
http://community.jboss.org/message/606679#606679

I guess you use "match-schema" instead of "match-catalog" in reveng.xml


Top
 Profile  
 
 Post subject: Re: Problem in Hibernate tool reverse engineering
PostPosted: Mon Jun 06, 2011 10:23 pm 
Newbie

Joined: Mon Jun 06, 2011 3:02 am
Posts: 2
Thanks for the reply,
I tried but it doesn't work for me, it doesn't show any error log, tried many times but no use.

this is my hib cfg file
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE hibernate-configuration PUBLIC
"-//Hibernate/Hibernate Configuration DTD 3.0//EN"
"http://hibernate.sourceforge.net/hibernate-configuration-3.0.dtd">
<hibernate-configuration>
<session-factory>
<property name="hibernate.bytecode.use_reflection_optimizer">false</property>
<property name="hibernate.connection.driver_class">com.mysql.jdbc.Driver</property>
<property name="hibernate.connection.password">xxxxxx</property>
<property name="hibernate.connection.url">jdbc:mysql://localhost:3306/test</property>
<property name="hibernate.connection.username">root</property>
<property name="hibernate.dialect">org.hibernate.dialect.MySQLDialect</property>
<property name="hibernate.search.autoregister_listeners">false</property>
</session-factory>
</hibernate-configuration>



hibernate.reveng.xml

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE hibernate-reverse-engineering PUBLIC "-//Hibernate/Hibernate Reverse Engineering DTD 3.0//EN" "http://hibernate.sourceforge.net/hibernate-reverse-engineering-3.0.dtd" >

<hibernate-reverse-engineering>
<table-filter match-catalog="test" match-name="registration" />
<table-filter match-catalog="test" match-name="user" />
</hibernate-reverse-engineering>

added mysql connecotr jar in class path ,and out put directry as src folder


please suggest.


Top
 Profile  
 
 Post subject: Re: Problem in Hibernate tool reverse engineering
PostPosted: Mon Jun 13, 2011 2:53 am 
Senior
Senior

Joined: Tue Aug 04, 2009 7:45 am
Posts: 124
Some DBs require same case values. Are your tables named "user" and "registration", but not "USER" and "REGISTRATION" in database? Same question for catalog?


Top
 Profile  
 
 Post subject: Re: Problem in Hibernate tool reverse engineering
PostPosted: Wed Jun 15, 2011 2:24 am 
Senior
Senior

Joined: Tue Aug 04, 2009 7:45 am
Posts: 124
Did this help?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 5 hours [ DST ]


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
© Copyright 2014, Red Hat Inc. All rights reserved. JBoss and Hibernate are registered trademarks and servicemarks of Red Hat, Inc.