hey guys, i have an interesting problem regarding the way hibernate maps property names to get and set methods. I may have missed the specification of the naming somewhere in the docs however bare with me.
I have a property named: c1000$
I think it maps to a get method named : C1000$ ()
or is it this? : c1000$() //since the second character is not a lower case letter?
however I am unsure of this and when I do so hibernate sometimes
maps the property to the get and set method and other times it does not.
So what I'm wondering is (especially if your familiar with the way hibernate
reads and maps the property name to the method names) would doing
something like this help?
property name : cc1000$
method name : getCc1000$()
I'm not too familiar with JavaBean naming convention but i suppose this
would reduce the ambiguity with the second character not being of lowercase.
Thanks in advanced,
Yu Wai Wong
|