I am a bit confused with naming convention of hibernate.cfg.xml and hibernate.properties parameters:
"hibenate." prefix is present
3.5. Optional configuration properties (hibernate.properties)
Code:
hibernate.dialect
hibernate.show_sql
...
Using the EHCache Plugin (hibernate.cfg.xml)
Code:
<property name="hibernate.cache.provider_class">net.sf.ehcache.hibernate.Provider</property>
"hibernate." prefix is not present3.8. XML Configuration File (hibernate.cfg.xml)
Code:
<property name="dialect">net.sf.hibernate.dialect.MySQLDialect</property>
<property name="show_sql">false</property>
..
It is not obvious when I have to use "hibernate." prefix for property names and when it is not obligatory. As I got in hibernate.cfg.xml I can omit "hibernate." property name prefix. Am I right?