Hibernate Books

All times are UTC - 5 hours [ DST ]



Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: [Hibernate Search]default indexBase, trouble on reindexation
PostPosted: Thu Jun 21, 2012 5:58 am 
Newbie

Joined: Thu Jun 21, 2012 4:23 am
Posts: 2
Hi,

I use hibernate search 4.10 on a JPA /spring 3.1.1 context. My app is deployed in a tomcat 6.0 on linux server.

I defined hibernate.search.default.indexBase to a specifc directory
and hibernate.search.default.directory_provider to 'filesystem'.

When i execute a mass indexation, hibernate search should use the indexBase directory.

But it creates too some directories in classes and logs directories where it stores its indexes.
The indexBase directory seems to be updated too.

I don't know where the problem comes from or if it is a bug.

Does anyone know what might be wrong? Thanks for help in advance.

Olivier


Top
 Profile  
 
 Post subject: Re: [Hibernate Search]default indexBase, trouble on reindexation
PostPosted: Thu Jun 21, 2012 6:14 am 
Hibernate Team
Hibernate Team

Joined: Fri Oct 05, 2007 4:47 pm
Posts: 2296
Location: Third rock from the Sun
Quote:
But it creates too some directories in classes and logs directories where it stores its indexes.
The indexBase directory seems to be updated too.

Hi, can you be more specific? what directories are created?

_________________
Sanne
http://in.relation.to/


Top
 Profile  
 
 Post subject: Re: [Hibernate Search]default indexBase, trouble on reindexation
PostPosted: Thu Jun 21, 2012 7:45 am 
Newbie

Joined: Thu Jun 21, 2012 4:23 am
Posts: 2
hi,

on the server, directories and files i found in classes and logs directories seem to be the same as those in the indexBase repository.

the log directory is defined in myapps/WEB-INF/classes/log4j.xml and external to the app, something like /logs. How could indexation write in ?

Olivier


Top
 Profile  
 
 Post subject: Re: [Hibernate Search]default indexBase, trouble on reindexation
PostPosted: Thu Jun 21, 2012 8:04 am 
Hibernate Team
Hibernate Team

Joined: Fri Oct 05, 2007 4:47 pm
Posts: 2296
Location: Third rock from the Sun
Hi,
I've never seen something like that happening. If you could upload a test somewhere, I'd be happy to have a look.

_________________
Sanne
http://in.relation.to/


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours [ DST ]


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
© Copyright 2014, Red Hat Inc. All rights reserved. JBoss and Hibernate are registered trademarks and servicemarks of Red Hat, Inc.