-->
These old forums are deprecated now and set to read-only. We are waiting for you on our new forums!
More modern, Discourse-based and with GitHub/Google/Twitter authentication built-in.

All times are UTC - 5 hours [ DST ]



Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 1 post ] 
Author Message
 Post subject: Problem mit Hibernate in Standalone-Applikation
PostPosted: Sat Jul 16, 2016 6:22 am 
Newbie

Joined: Sat Jul 16, 2016 5:55 am
Posts: 1
Hallö

Hab das Problem, das Hibernate in Standalone-Applikation das Problem hat,
Entity Klassen im angegebenen jar zu finden.
In Eclipse lässt sich das mit entsprechendem Setzen des classpaths noch korrigieren.
Aber ausserhalb von Eclipse (im Deployment) hat man das Problem, das Hibernate nur absolute Pfade akzeptiert,
was gar nicht geht und absolut nicht portabel ist, z.B. ein Server der ja beliebig
irgendwo installiert werden kann.
Hier meine persistence.xml:

<persistence-unit name="mydb" transaction-type="RESOURCE_LOCAL">
<provider>org.hibernate.jpa.HibernatePersistenceProvider</provider>
<jar-file>../services/entity.jar</jar-file>
</persistence-unit>

Anm.
Klassen einzutragen sind keine Lösung da 3-party Entities kommen und gehen können,
je nach Bedarf des Deployers.

Im Moment sehe ich nur die Möglichkeit die persistence.xml vor dem Serverstart programatisch
umzuschreiben. Vielleicht hatte schon wer dieses Problem auch mal, und eine bessere Lösung als diese?

Danke!!


Top
 Profile  
 
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 1 post ] 

All times are UTC - 5 hours [ DST ]


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
cron
© Copyright 2014, Red Hat Inc. All rights reserved. JBoss and Hibernate are registered trademarks and servicemarks of Red Hat, Inc.