Well, doesn't really seem to be an error, but wouldn't it be more coherent if the listing §7.5.1, which reads now
Code:
...
<join table="PersonAddress"
inverse="true"
optional="true">
<key column="addressId"/>
<many-to-one name="person"
column="personId"
not-null="true"/>
</join>
</class>
would be rewritten to
Code:
...
<join table="PersonAddress"
inverse="true"
optional="true">
<key column="addressId"
unique="true"/> <!-- !!! -->
<many-to-one name="person"
column="personId"
not-null="true"/>
</join>
</class>
?
The
unique attribute makes sense and is used for key columns in other join table examples, e.g. §7.3.2 and §7.5.2. I guess the correction would make things more coherent and thus more understandable.