Hello,
I've got two related questions on hibernate_sequence:
1. Is it possible to change the name of the default hibernate sequence (hibernate_sequence) to something else? I've searched wuite a lot now on forums/google/jira without success. Our customer has a naming policy on his Oracle sequences and hibernate_sequence doesn't fit :)
2. I'm aware of the possibility of naming the sequences with
Code:
<generator class="sequence">
<param name="sequence">person_id_sequence</param>
</generator>
However, that forces one sequence per table. IMO in our application, that would not be needed (not that much expected load).
So my question is this:
are there any objections/drawbacks to use ONE sequence for all tables, using:
Code:
<generator class="sequence">
<param name="sequence">mySequence</param>
</generator>
and just not create the default hibernate sequence (hibernate_sequence) at all? Is the default sequence needed for anything else by hibernate?
Thx for reading/replying.
christian