Firstly thanks for the help .....
Now I would like to explain what was the blunder I had made ..
My private data name was unitprice and I had made my Getter and Setter methods with the following naming convention
Code:
public void setUnitPrice(Double unitprice)
{
.....
.......
}
Hence now I would like to inform all the hibernate users not to use the name of the Getter and Setter methods as these but only make the first character after get or set as capital as getUnitprice() setUnitprice
BesToFlock